当前位置:首页 > 问答

通达信均线斜率公式

我来帮TA回答

通达信如何编写均线下跌的斜率

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
忽略以上公式。
应该是计算均线下跌的角度比较合适,软件中好像没有计算斜率的。
角度计算有这样的公式。

10日均线斜率向上 如何描述? (通达信)

从斜率的定义上来看r=(V1-V0)/t,其实可以很明显地看出只要十日均线的当天值大于昨天值,那么当天的斜率就为正值,也就是向上。对应的程序是:
MA10:=MA(C,10);
CON:MA10>REF(MA10,1);
另注,斜率的变化是一个值得研究的问题。

请高手做一个通达信选股公式{股价K线上升斜率}。 比如600016民生银行这样的股上涨初期可以选出来...

任何技术分析系统,都是滞后的,判断股价的高低,定价,是公司的基本面,人的心态,抓助机会,结合技术判断,
技术涉及到,均线,成交量,行业,大盘,历史价位,公司的价值等等

一条均线的角度大于45度,通达信选股公式如何编写呢?

角度:=atan((MA(C,n)/ref(MA(C,n),1)-1)*100)*57.3;
大于45度选股:角度>45;
n日均线,其中的n值自己设置修改。
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

均线角度如何确定

用画线工具将低点依次连接,再在你所选的基点画一根水平线就可以了。无论放大还是缩小,角度是不会变得的。如果是下跌,就将各高点依次连接,道理是一样的。

均线的角度公式怎样编

看看这个画线公式行不行?图片演示在下面网址里.
HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINICK2;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINICK2;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINICK2;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;